Chapter 8
Channels & Masks



CHANNELS



Understandmg Channels

« When we |look at a colored
Image on our monitor, we
are actually looking at a
combination of only three
colors: red, green, and blue.
It Is a combination of the
three colors that produce
the millions of colors we see.

« An image can be called a
channel sandwich. Look af
the image above. The
image is  three  color
channels that make up the
final picture.




Displaying Channels

« The Channels palette is located in the same window
as the Layers palette by default. This location can be
easily changed, so if you cannot find the Channels
palette, you can open the window by selecting
Window -> Show Channels. Clicking on the Channels
tab at any fime will activate the Channels palette.

« To work on any channel individually, click on the
appropriate channel listing in the Channels palette.
The colored image will change to a gray scale image
which represents the distribution of that color. When a
channel is active, any edits in the main screen will
affect only that channel.



Displaying Channels

« Open cat.psd. Switch to channels palette and apply
a Noise effect only to the Red channel by selecting
Filter -> Noise -> Add noise.

* Then switch to the Layers palette. Blur will only effect
the red pixels.
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The RGB/CYMK Color Channels

« The RGB/CYMK color channels are used to give you
an indication of the separate color channels
contained within your image. When combined, they
create the full color spectrum of an Iimage.
Separated, they produce the individual color ‘plates’
that make up the image's color; Red-Green-Blue /
Cyan-Yellow-Magenta-Black.

 You can apply most of Photoshop's filters/effects to
these channels; to produce interesting imaging
effects. Ones that you can't use will be dimmed out
in the menus. But be careful doing this, as these
channels will directly produce a destructive editing
result on your image.



Alpha Channels

Aloha channels are more widely used to either create,
edit, or save specific types of selections.

v Aloha channels are not part of your image's color
composition, and have no effect on that directly.

v They are 256 gray scale in color.

v You can apply most of Photoshop's filters to them to
create complex and interesting types of selections.

v Channels are also used as Texture Channels within the
Lighting Effects filter, to create a minimal type of 3D
effect on a colored area of a layer, or a specific
selected area of an object on a layer.



Alpha Channels

v Quick Masks & Layer Masks use a temporary Alpha
channel to store your selection/masking information.

v You can use any of Photoshop's painting tools to
create and/or edit a channel. Menu options that you
can't use will be dimmed (non selectable) in the menu
lists.

v Channels can be loaded as active selections in the
same manner that layers can; i.e. by holding the Cirl
key down while clicking on them.



Creating an Alpha Channel

« Selection information is kept as
channels in Photoshop. Switch
to the Channels Paleffe and
click on the New Channel icon
to create a new channel.
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3D Effects With Alpha Channels

* |f Is not easy to understand the use of channels
without using channel applications on an image.
Channels are only used in some specific actions.
Making 3D metal look like images is one of them.

 Create a document 500 X 400 with a 72 dpi. black
background in RGB mode.

« Type Light with the font Calisto MT Bold, 120 pft. color:
light grey.



3D Effects With Alpha Channels

Rasterize the type, load the selection
of Light text by CIRL+ clicking on the
layer thumbnail and switch to the
Channels Palette.

Create a new channel and fill it with LIGHT

white. Any effect we give under the
channels palette will not directly effect
the real Light text in the Layers palette.

Now when Light is still selected we will
apply the Blur Filfer 4 times with the
given settings.

Click on Filter -> Blur -> Gausian Blur.




3D Effects With Alpha Channels

10 pixels 5 pixels

LIGHT | LIGH]T




3D Effects With Alpha Channels

« Switch to the Layers palette and select the Light
Layer if not selected. As you see no effect is applied
to our image yet. Now go to Filter -> Render ->
Lightning Effects. And apply the settings given:
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3D Effects With Alpha Channels

« We load the Alphal layer to apply the effect we
have given in the Channels Palette. Go to Image- >
Adjust -> Curves and shine the text. Then select the
text and blur it 1 px. From Filter -> Blur -> Gaussian
Blur.
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MASKS



What is a Mask?

Masks are simply a selection. They perform the exact
same duty as the little marching ants in a selection
boundary. The difference is you can make more complex
selections with mask fools. Masks are incredibly useful for
blending photos and hiding portions of images without
altering them directly.

For example: You will paint door but you don't want the
door handle to be painted. You cover the handle with
masking tape and after finishing painting the door, you
remove the masking tape. Result: The door handle is paint
free. Masks in Photoshop do the same job as masking tape
does in painting.

In conclusion “Masking comes down to one thing: getting
a good ftransition between what's selected and what
isn't.” Masks help us to do selections that would be
Impossible using only selection tools.



Quick Masks

 Quick mask is a special mode in Photoshop that is
devoted to defining a selection. While Photoshop Is
IN Quick mask mode, all Photoshop functions, tools
and commands work for defining the selected
area. While in Quick Mask Mode no matter what
you draw on the canvas or which effect you give,
the drawings and filters will only effect the selection
but not the layer.



Quick Masks

To switch to Quick Mask Mode:
v' Click on the Quick Mask Mode icon on the Toolbar. |

In quick mask mode there are two main colors; black and
white. Black defines the area that will not be included to the
selection and white means the area that will be selected. The
tricky point here is that when you select black as the color and
try to fill anywhere with black, the color on the screen will be
purple: the default quick mask mode color. So don't be
confused. You select black but screen color will be purple. The
area you cover with purple will be excluded from the selection
and only the parts with no color wil be included in the
selection.

To switch to standard mode Click on the Standard Mode icon
on the toolbar which is located in the same place where the
Quick Mask button is.




Practice : Applying Quick Mask to an Image

* By using the Zoom Tool on the toolbox, zoom in on the
eyes of the big cat.

« Switch to the Quick Mask Mode. Be sure that black is the
foreground color in this mode. Select an average size
brush and fill both of the eyes with quick mask color. Do
not exceed the boundaries of eyes.
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Practice : Applying Quick Mask to an Image

.
Switch to .’rhe S.Tdndcrd Mode. [T "= — =
Everywhere in the picture except the | .
eyes is selected now. Click on Image ;
-> Adjustments -> Black and White | == _ BT Do
and apply these settings. Groens IERE

Cyans: 23 %
Blues: B 10 %
Magentas: B E %

] Tirt

Now our figer has furned to white but the eyes are sftill the same
color. By using Quick Mask, although eyes and the face are on
the same layer, we have avoided Photoshop applying an effect
to the eyes while it was being applied to the face.



Practice : Color Transition with Quick Mask Mode

Open the file sea.psd.

Click on the Quick Mask
mode icon to switch fo the
Quick Mask Mode.

Time to define our selection.
Click on the Gradient Tool
lcon and select the
Foreground to Background
gradient, press OK.

As you see our foreground
and background colors are
white and black. Drag the
cursor from the boftom-right
corner to the top-left corner
to draw a gradient.

Gradient Type: | Solid v

Smoothness: | 100 » 2%




Practice : Color Transition with Quick Mask Mode

« |Instead of filling the screen with black and white our
gradient tool is just applying a quick mask color and
transparent color. On the picture above, the
transparent parts show the upcoming selection. Now
click on the Standard Mode button to go to the
Standard Mode. You will see a selection on your
Ccanvas.




Practice : Color Transition with Quick Mask Mode

« Define any foreground color on the Toolbox and Click Edit -> Fill -
> Foreground color. Here is the result.




Layer Masks

A layer mask in Photoshop is basically a way of hiding and

revealing certain parts of a layer. Layer masks cannot be
applied to Background or text layers.

Open the file cat_portrait.psd, select and unhide Layer2. The
cat will not be seen for a while.
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Layer Masks

« Now to create a layer mask: go to Layer ->
Layer Mask -> Reveal All or click on the Add | |- | Chames | ":E“‘Lﬁ_b‘
Layer Mask icon on the Layers Palette. A m:'uj+: g FLW
white background thumbnail has come to
the Layer2 now. This means the whole of ||®
Layer 2 has turned to a mask and is waifing || g [l ...
to be cut. —

« When you paint on the mask using black,
you are “cutting” the mask away to reveadl
what's beneath. Any white part of the mask
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Is opaque, and the black part is tfransparent
and any shades of gray are varying
opacities.

 Time to cut the mask. Select the brush tool and choose an average
size brush from brush toolbar which is located on top of the
Photoshop screen.



Layer Masks

 Be sure that your foreground color is black. Decrease the
opacity of layer2 a bit fo see beneath it and draw a circle
like shape on the canvas to reveal the face of the cat.
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Layer Masks

« Some parts of the white thumbnail on layer2 has turned to
black now, which means | have cut those parts of the mask.

Change the opacity of layer2 to %100 now.
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Now you may ask:
Why did we use
Layer Mask for this
applicatione We
could have done
this with the Eraser
Toole

To answer this
question let's go
forward a few
more steps.



Layer Masks

« Click on the link between the white thumbnail and the picture
thumbnail of Layer2. By doing this we freed the mask from ifs
background and mobilized it.
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Layer Masks

« Click on the white thumbnail to select the mask. Then using the
Move Tool position the mask somewhere different than it's previous
location.

* AS YyoU see, you can move the position of the mask without moving
the wood texture. This feature is not available in any other selection
tools other than masking.



Layer Masks

* Applying a Mask
o When the mask layer is selected follow Layer -> Layer Mask ->

Apply. Once you select “apply” you can't change the mask's
position anymore.

« Deleting a Mask

o When the mask layer is selected follow Layer -> Layer Mask ->
Delete. The second way is by dragging the mask
thumbnail(white thumbnail) to the Trash bin on the Layers
palette.



Vector Masks

The Custom Shape tools are a kind of layer mask. When
you draw a custom shape, a vector mask layer is created
for the shape. As seen on the layers palette the blue color
Is only filled to the shape area.
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Vector Masks

 To see the function of the custom shape in a vector mask,
when the mask layer is the active layer, go to Layer ->
Vector Mask -> Disable Vector mask.

 Because the custom shape is disabled, color is filled to the

whole of the image.

 To enable the vector mask go to Layer -> Vector Mask ->

Enable.

Vector Mask Disabled
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Rasterize a Vector Mask

 To rasterize a vector mask [ Coyers » | Chomnes [ paths | .~
when the mask layer s = S

Lock: [ &+ @ Fill: 100% *

selected go to Layer -> ,_.

Rasterize. Here fthere are
three options.

« Rasterize Shape: This opfion
rasterizes the shape and

everywhere  except  the oo srape
shape will be fransparent. —
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shape will be locked to it's
position but you will be free to :
move the color inside the shape. ||» Backeiound a
To move the content, select the
Move Tool aond drag the
content.
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Rasterize a Vector Mask

* Rasterize Vector Mask: By rasterizing the vector mask you
mask all parts of the layer which are out of the shape.

- :H;-
| Layers = | Channels | Paths | =1
Morrnal w Opacity! 1009 »

Lock: || »+ @ Fill: | 1009 »

“ee |
- Yol | Shape 1 '
_=.

- Fackground |

s-a-ﬁ,lﬂﬂ__i_ui’i..; ‘




Practice : Baby

e 5

Baby

=® Open the file baby.psd and desaturate all parts of the image except the baby. Use the Quick Mask.
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Practice : Zambak

=9 Create a document 900 X 700 with 72 dpi. Create and arrange the layers as given. Apply a rainbow
gradient to a layer. Make a mask from the ZAMBAK text and move it around the canvas.
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The End



